
Introduction to SPSS 

SPSS (Statistical Package for the Social Sciences) is a versatile and 
responsive program designed to undertake a range of statistical procedures.  
SPSS software is widely used in a range of disciplines and is available from 
all computer pools within the University of South Australia. 

It’s important to note that SPSS is not the only statistical software – there 
are many others that you may come across if you pursue a career that 
requires you to work with data.  Some of the other more common statistical 
packages include Stata and SAS (and there are many others).  The focus for 
this session, however, is on SPSS. 

Features of SPSS 

 The data from any survey collected via Survey Gizmo gets easily exported to SPSS 

for detailed and good analysis. 

 In SPSS, data gets stored in.SAV format. These data mostly comes from surveys. 

This makes the process of manipulating, analyzing and pulling data very simple. 

 SPSS have easy access to data with different variable types. These variable data is 

easy to understand. SPSS helps researchers to set up model easily because most 

of the process is automated. 

 After getting data in the magic of SPSS starts. There is no end to what we can do 

with this data. 

 SPSS has a unique way to get data from critical data also. Trend analysis, 

assumptions, and predictive models are some of the characteristics of SPSS. 

 SPSS is easy for you to learn, use and apply. 

 It helps in to get data management system and editing tools handy. 

 SPSS offers you in-depth statistical capabilities for analyzing the exact outcome. 



 SPSS helps us to design, plotting, reporting and presentation features for more 

clarity 

Data View 

The data view is structured as rows and columns. By importing a file or adding data 
manually, we can work with SPSS 

When you view data in SPSS, each row in the Data View represents a case, and each 
column represents a variable. 

Cases represent independent observations, experimental units, or subjects. For 
example, if the data are based on a survey of college students, then each row in the data 
would represent a specific college student who participated in the study.  

Variables are attributes, characteristics, or measurements that describe cases. For 
example, your data might include information such as each college student’s date of 
birth, gender, or class rank. Each of these pieces of information is a variable that 
describes each case (college student). 

 

VARIABLE VIEW 

You can define information about your variables by accessing the Variable View tab 
(at the bottom of the Data Editor window). The Variable View tab displays 
information about the variables in your data. You can get to the Variable View window 
in two ways: 

 In the Data Editor window, click the Variable View tab at the bottom. 



 In the Data Editor window, in the Data View tab, double-click a variable name at 
the top of the column. This method has the advantage of taking you to the specific 
variable you clicked. 

The Variable View tab displays the following information, in columns, about each 
variable in your data: 

NAME 

The name of the variable, which is used to refer to that variable in syntax. Variable 
names can not contain spaces. Note that when you change the name of a variable, it does 
not change the data; all values associated with the variable stay the same. Renaming a 
variable simply changes the name of that variable while leaving everything else the 
same. For example, we may want to rename a variable called Sex to Gender. 

To change a variable's name, double-click on the name of the variable that you wish to 
re-name. Type your new variable name. 

TYPE 

The type of variable (e.g. numeric, string, etc.). (See the Variable Types tutorial for 
descriptions of the variable types in SPSS.) 

 

 

 

 

To change a variable's type, click inside the cell corresponding to the “Type” column for 
that variable. A square "..." button will appear; click on it to open the Variable Type 
window. Click the option that best matches the type of variable. Click OK. 



WIDTH 

The number of digits displayed for numerical values or the length of a string variable. 

To set a variable's width, click inside the cell corresponding to the “Width” column for 
that variable. Then click the "up" or "down" arrow icons to increase or decrease the 
number width. 

DECIMALS 

The number of digits to display after a decimal point for values of that variable. Does not 
apply to string variables. Note that this changes how the numbers are displayed, but 
does not change the values in the dataset. 

To specify the number of decimal places for a numeric variable, click inside the cell 
corresponding to the “Decimals” column for that variable. Then click the “up” or “down” 
arrow icons to increase or decrease the number of decimal places. 

Example: If you specify that values should have two decimal points, they will display as 
1.00, 2.00, 3.00, and so on. 

LABEL 

A brief but descriptive definition or display name for the variable. When defined, a 
variable's label will appear in the output in place of its name. 

Example: The variable expgradate might be described by the label “Expected date of 
college graduation". 

VALUES 

For coded categorical variables, the value label(s) that should be associated with each 
category abbreviation. Value labels are useful primarily for categorical (i.e., nominal or 
ordinal) variables, especially if they have been recorded as codes (e.g., 1, 2, 3). It is 
strongly suggested that you give each value a label so that you (and anyone looking at 
your data or results) understands what each value represents. 

When value labels are defined, the labels will display in the output instead of the 
original codes.Note that defining value labels only affects the labels associated with each 
value, and does not change the recorded values themselves. 

Example: In the sample dataset, the variable Rank represents the student's class rank. 
The values 1, 2, 3, 4 represent the categories Freshman, Sophomore, Junior, and Senior, 
respectively. Let's define the category labels for the Rank variable in the sample data. 

Under the column “Values,” click the cell that corresponds to the variable whose values 
you wish to label. If the values are currently undefined, the cell will say “None.” Click the 
square “…” button. The Value Labels window appears. 



 

Type the first possible value (1) for your variable in the Value field. In 
the Label field type the label exactly as you want it to display (e.g., "Freshman"). 
Click Add when you are finished defining the value and label. Your variable value and 
label will appear in the center box. Repeat these steps for each possible value for your 
variable. When all of the labels have been defined, the Value Labels window should look 
like this: 

 

 

 

 



Click OK at the bottom of the window. 

If you wish to change or remove a value and label that you have added to the center 
dialog box, do the following: 

 To change a specific value or label, highlight the value/label in the center text box 
in the Value Labels window. Now the selected value/label will be highlighted 
yellow. Make changes to the selected value or label as needed. Click Change. The 
changes will be applied to the value/label you highlighted. 

 To remove a specific value/label, highlight the value/label in the center text box. 
Click Remove. The selected value/label will be removed from the center text 
box. 

MISSING 

User-defined data values (or ranges of values) should be treated as missing. Note that 
this property does not alter or eliminate SPSS's default missing value code for numeric 
variables ("."). This column merely allows the user to specify up to three unique missing 
value codes for the given variable; or, to specify a range of numbers to treat as missing, 
plus one additional unique missing value code. 

To set user-defined missing value codes, click inside the cell corresponding to the 
“Missing” column for that variable. A square button will appear; click on it. 

 

Click the option that best matches how you wish to define missing data and enter any 
associated values, then click OK at the bottom of the window. 

Note that you may enter numbers or letters as discrete missing value codes in the 
"discrete missing values" boxes. 

Caution: If you have a dataset with string variables, blank cells are not automatically 
recognized as missing values. In order for blanks to be recognized as missing values, you 
can either: 

 add a space character (Spacebar key) as a discrete missing value code (either in 
the Variable View or using syntax), or 

 use the Automatic Recode procedure to recode the string variable into a 
labeled, numeric categorical variable with blanks recoded into a special missing 
value code. 

The latter option works well if there are a limited number of unique string values, but is 
a poor option if there are many unique variations in the strings (e.g. capitalization, 
spelling, spacing). 



COLUMNS 

The width of each column in the Data View spreadsheet. Note that this is not the same 
as the number of digits displayed for each value. This simply refers to the width of the 
actual column in the spreadsheet. 

To set a variable's column width, click inside the cell corresponding to the “Columns” 
column for that variable. Then click the “up” or “down” arrow icons to increase or 
decrease the column width. 

ALIGN 

The alignment of content in the cells of the SPSS Data View spreadsheet. Options 
include left-justified, right-justified, or center-justified. 

To set the alignment for a variable, click inside the cell corresponding to the "Align" 
column for that variable. Then use the drop-down menu to select your preferred 
alignment: Left, Right, or Center. 

MEASURE 

The level of measurement for the variable (e.g., nominal, ordinal, or scale). 

Some procedures in SPSS treat categorical and scale variables differently. By default, 
variables with numeric responses are automatically detected as “Scale” 
variables. If the numeric responses actually represent categories, you must change the 
specified measurement level to the appropriate setting. 

To define a variable's measurement level, click inside the cell corresponding to the 
“Measure” column for that variable. Then click the drop-down arrow to select the level 
of measurement for that variable: Scale, Ordinal, or Nominal. 

 

Scale of Measurement in SPSS 

Measurement levels refer to different types of variables that imply how to analyze them. 

Different types of measurements are 

1. nominal variables; 

2. ordinal variables; 

3. interval variables; 

4. ratio variables. 

 



Nominal Variables 
A nominal variable is a variable whose values don't have an undisputable 

order.So let's say we asked respondents in which country they live and the answers 

are 

 the Netherlands; 

 Belgium; 

 

Ordinal Variables 
Ordinal variables hold values that have an undisputable order but no fixed unit of 

measurement.Some fixed units of measurement are meters, people, dollars or 

seconds. However, there's no fixed unit of measurement for a question like“how did 

you like your food?”with the following answer categories: 

 

Interval Variables 
Interval variables have a fixed unit of measurement but zero does not mean 

“nothing”.One of the rare examples is “in which year did it happen?” Ignoring leap 

days, years are a fixed unit of measurement for time. However, the year zero doesn't 

mean “nothing” with regard to time. 

As a consequence, 

Ratio Variables 
Ratio variables have a fixed unit of measurement and zero really means 

“nothing.”An example is weight in kilos. A kilo is a fixed unit of measurement because 

it always represents the exact same weight. Also, zero kilos corresponds to “nothing” 

with regard to weight. As a consequence, 

 

Output Viewer Window 

The Output View is where you see the results of your various queries such as frequency 
distributions, cross-tabs, statistical tests, and charts. 



 

 iewer windows can be saved for later use; just use File > Save to write 
the content of a window to a file and late use File > Open > Output to view 
it again. 

 You can open several Viewer Windows at the same, use File > New > 
Output to do so (Copy/Paste > Copy between windows is easy). When you 
have two or more Viewer Windows open, the new output will go to 
the last window opened. If you want to direct output to another of the 
windows, you should click on  which appears on all Viewer Windows 
where the output is NOT directed to; you can also use Utilities > 
Designate Window to do so. 

 Printing output 
o On the print dialog, choose to print All visible output or Selected 

output. "Visible" means all visible frames in the window, i.e. you 
can simply hide frames that you do not want to be printed. Make sure to 
understand that "selected" means the selected frame(s), i.e. if you the current selection is only a title (in the 
example above "Graph" is a title frame) you will get only a single word printed... 

o As tables can be become quite big, they might print on several 
pages which is not always what you want. Before printing it is 
highly recommended to use File > Print Preview 

o The Insert menu has options for inserting and removing page 
breaks and add page titles. 

. 

 The full content of a viewer window (File > Export or individual frames 
(Export from the context menu) can be exported into various formats 
(html, PDF, Word (RTF), Power Point, Excel, etc. ) 

SYNTAX EDITOR WINDOW 



SPSS syntax is a programming language that is unique to SPSS. It allows you to write 
commands that run SPSS procedures, rather than using the graphical user interface. 

Syntax allows users to perform tasks that would be too tedious or difficult to do using 
the drop-down menus. This is the case when you are re-running the same analysis many 
times, or doing complex transformations on data. Syntax also provides a record of how 
you transformed and analyzed your data, and allows you to instantly reproduce those 
steps at any time. 

 

How do you import data into SPSS? 

To open your Excel file in SPSS: 

File, Open, Data, from the SPSS menu. 

Select type of file you want to open,Excel *. xls *. xlsx, *. xlsm . 

Select file name. 

Click 'Read variable names' if the first row of the spreadsheat contains column headings. 

Click Open. 

RECODING VARIABLE 

Sometimes you will want to transform a variable by combining some of its categories or values 
together. For example, you may want to change a continuous variable into an ordinal 
categorical variable, or you may want to merge the categories of a nominal variable. In SPSS, 
this type of transform is called recoding. 

In SPSS, there are three basic options for recoding variables: 

1. Recode into Different Variables 
2. Recode into Same Variables 

Each of these options allows you to re-categorize an existing variable. Recode into Different 
Variables  syntax create a new variable without modifying the original variable, while Recode 
into Same Variables will permanently overwrite the original variable. In general, it is best to 
recode a variable into a different variable so that you never alter the original data and can easily 
access the original data if you need to make different changes later on. 

 

Recode in to Same Variable 



Recoding into a same variable transforms an original variable into same variable. That 
is, the changes  overwrite the original variable; they are instead applied to a copy of the 
original variable under a new name. 

Recoding into the same variable (Transform > Recode into Same Variables) works 
the same way as described above, except for that any changes made will permanently 
alter the original variable. That is, the original values will be replaced by the recoded 
value 

In general, it is good practice not to recode into the same variable because it overwrites 
the original variable. If you ever needed to use the variable in its original form (or 
wanted to double-check your steps), that information would be lost. 

To recode into different variables, click Transform > Recode into same Variables. 

 

The Recode into same Variables window will appear 



 

The left column lists all of the variables in your dataset. Select the variable you wish to 
recode by clicking it. Click the arrow in the center to move the selected variable to the 
center text box 

 

Old Value: Specify the type of value you wish to recode (e.g., a specific value, missing 
data, or a range of values) and the specific value to be recoded (e.g., a value of “1” or a 
range of “1-5”). 

 Value: Enter a specific numeric code representing an existing category. 
 System-missing: Applies to any system-missing values (.) 
 System- or user-missing: Applies to any system-missing values (.) or special 

missing value codes defined by the user in the Variable View window 



 Range: For use with ordered categories or continuous measurements. Enter the 
lower and upper boundaries that should be coded. The recoded category will 
include both endpoints, so data values that are exactly equal to the boundaries 
will be included in that category. 

 Range, LOWEST through value: For use with ordered categories or continuous 
measurements. Recode all values less than or equal to some number. 

 Range, value through HIGHEST: For use with ordered categories or continuous 
measurements. Recode all values greater than or equal to some number. 

 

Click on continue button 

 

 

Recode into Different Variables 
 

Recoding into a different variable transforms an original variable into a new variable. 
That is, the changes do not overwrite the original variable; they are instead applied to a 
copy of the original variable under a new name. 

To recode into different variables, click Transform > Recode into Different Variables. 



 

The Recode into Different Variables window will appear. 

 

The left column lists all of the variables in your dataset. Select the variable you wish to 
recode by clicking it. Click the arrow in the center to move the selected variable to the 
center text box, (B). 

A  Input Variable -> Output Variable: The center text box lists the variable(s) you 
have selected to recode, as well as the name your new variable(s) will have after the 
recode. You will define the new name in (C). 

B  Output Variable: Define the name and label for your recoded variable(s) by typing 
them in the text fields. Once you are finished, click Change. Now the center text box, 



(B), will display both the name of the original variable as well as the name for the new 
variable (e.g., “Height --> Height_categ”). 

C  Old and New Variables: Click the Old and New Values to specify how you wish to 
recode the values for the selected variable. 

D  If: The If option allows you to specify the conditions under which your recode will be 
applied. (We discuss the If option in more detail later in this tutorial.) 

 

OLD AND NEW VALUES 

Once you click Old and New Values, a new window where you will specify how to transform the values will appear. 

1 Old Value: Specify the type of value you wish to recode (e.g., a specific value, 
missing data, or a range of values) and the specific value to be recoded (e.g., a value of 
“1” or a range of “1-5”). 

When recoding variables, always handle the missing values first! The most common 
recoding errors happen when you don't tell SPSS explicitly what to do with missing 



values: SPSS may recode missing values into one of the new valid categories. This is 
especially true if using the "Lowest thru", "thru Highest", or "Range - through" options. 

 Value: Enter a specific numeric code representing an existing category. 
 System-missing: Applies to any system-missing values (.) 
 System- or user-missing: Applies to any system-missing values (.) or special 

missing value codes defined by the user in the Variable View window 
 Range: For use with ordered categories or continuous measurements. Enter the 

lower and upper boundaries that should be coded. The recoded category will 
include both endpoints, so data values that are exactly equal to the boundaries 
will be included in that category. 

 Range, LOWEST through value: For use with ordered categories or continuous 
measurements. Recode all values less than or equal to some number. 

 Range, value through HIGHEST: For use with ordered categories or continuous 
measurements. Recode all values greater than or equal to some number. 

 All other values: Applies to any value not explicitly accounted for by the 
previous recoding rules. If using this setting, it should be applied last. 

2 New Value: Specify the new value for your variable (i.e., a specific numeric code 
such as “2,” system-missing, or copy old values). 

3 Old -> New: Once you have selected the old and new values for your selected 
variable in (1) and (2), click Add in area (3), Old-->New. The recode that you have 
specified now appears in the text field. If you need to change one of the recodes that 
you have added to the Old-->New area section, simply click on the one you wish to 
change and make changes in (1) and (2) as necessary. 

You will need to repeat these steps for each value that you wish to recode. Once you 
have specified all the transformations that you wish to make for the selected variable, 
click the “Continue” button. 

 

Transpose of data  

Transpose creates a new data file in which the rows and columns in the original data file are 
transposed so that cases (rows) become variables and variables (columns) become cases. 
Transpose automatically creates new variable names and displays a list of the new variable 
names. 

Procedure to transport data in spss 

Step1. Create a  data set like this 



 

Step 2 

Click on data menu then click on transporse 

 

   

Step 3. 

 Change variable in to right side  



 

Step 4 then click OK button 

 

Inserting or Deleting Single Variables 

Sometimes you may need to add new variables or delete existing variables from your 
dataset. For example, perhaps you are in the process of creating a new dataset and you 
must add many new variables to your growing dataset. Alternatively, perhaps you decide 
that some variables are not very useful to your study and you decide to delete them from 
the dataset. Or, similarly, perhaps you are creating a smaller dataset from a very large 
dataset in order to make the dataset more manageable for a research project that will 
only use a subset of the existing variables in the larger dataset. 

INSERTING A VARIABLE 

To insert a new variable into a dataset: 

1. In the Data View window, click the name of the column to the right of of where 
you want your new variable to be inserted. 

2. You can now insert a variable in several ways: 
 Click Edit > Insert Variable; 
 Right-click an existing variable name and click Insert Variable; or 



 Click the Insert Variable icon ( ). 

A new, blank column will appear to the left of the column or cell you selected. 

New variables will be given a generic name (e.g. VAR00001). You can enter a new name 
for the variable on the Variable View tab. You can quick-jump to the Variable View 
screen by double-clicking on the generic variable name at the top of the column. Once in 
the Variable View, under the column “Name,” type a new name for the variable name 
you wish to change. You should also define the variable's other properties (type, label, 
values, etc.) at this time. 

DELETING A VARIABLE 

To delete an existing variable from a dataset: 

1. In the Data View tab, click the column name (variable) that you wish to delete. 
This will highlight the variable column. 

2. Press Delete on your keyboard, or right-click on the selected variable and click 
“Clear.” The variable and associated values will be removed. 

Alternatively, you can delete a variable through the Variable View window: 

1. Click on the row number corresponding to the variable you wish to delete. This 
will highlight the row. 



2. Press Delete on your keyboard, or right-click on the row number corresponding 
to the variable you wish to delete and click "Clear". 
 

Inserting or Deleting Single Cases 

Sometimes you may need to add new cases or delete existing cases from your dataset. 
For example, perhaps you notice that one observation in your data was accidentally left 
out of the dataset. In that situation, you would refer to the original data collection 
materials and enter the missing case into the dataset (as well as the associated values for 
each variable in the dataset). Alternatively, you may realize that you have accidentally 
entered the same case in your dataset more than once and need to remove the extra 
case. 

INSERTING A CASE 

To insert a new case into a dataset: 

1. In Data View, click a row number or individual cell below where you want your 
new row to be inserted. 

2. You can insert a case in several ways: 
 Click Edit > Insert Cases; 
 Right-click on a row and select Insert Cases from the menu; or 

 Click the Insert Cases icon ( ). 
3. A new, blank row will appear above the row or cell you selected. Values for each 

existing variable in your dataset will be missing (indicated by either a “.” or a 
blank cell) for your newly created case since you have not yet entered this 
information. 



4. Type in the values for each variable in the new case. 
 
 

DELETING A CASE 

To delete an existing case from a dataset: 

1. In the Data View tab, click the case number (row) that you wish to delete. This 
will highlight the row for the case you selected. 

2. Press Delete on your keyboard, or right-click on the case number and select 
“Clear”. This will remove the entire row from the dataset. 

 
 
Merging two files in SPSS 
     we can merge two files in spss  in two ways. They are 
Add cases   and Add variable 
 
Add variables 
   In  these method combining files with joining variables to target files 
 
  Steps  
1. Create two files here first file is mokeristudents and second file is details 



First open the first file mokeristudents 
    

  
2. Click on data->merge files->add variables 

  

 
3. Then browse the second file details  and click continue then ok 

     
Then file is merged 



   
    

Add cases method 
   In these method combining files with same field with additional rows 

 Create two files here first file is mokeristudents and second file is 
nadapuramstudents  
1. First open the first file mokeristudents 
 

 
2. Click on data->merge files->add cases 

 

 



3. Then browse the second file nadapuramstudnets  and click continue then ok 
 

 

4. Then click ok 

 
 

Split file 
Split file allows to temporarily divide a data file into subgroups, which share one or more 
common characteristics. These groups are then be analyzed seperately . 

When analyzing data, it is sometimes useful to temporarily "group" or "split" your data 
in order to compare results across different subsets. This can be useful when you want to 
compare frequency distributions or descriptive statistics with respect to the categories of 
some variable (e.g., Gender) - especially if you want separate tables of results for each 
group. 

To split your dataset, click Data > Split File. 



 

 

You can choose one of two ways to split the data: 

1. Compare groups 
2. Organize output by groups 

For both splitting methods, there are two considerations to be made: 

 The splitting variable(s) should be nominal or ordinal categorical. SPSS will not 
stop you from using a continuous variable as a splitting variable, but it is a bad 
idea to try to attempt this; SPSS will see each unique numeric value as a distinct 
category. 

 In order to split the file, SPSS requires that the data be sorted with respect to the 
splitting variable. By default, Sort the file by grouping variables is selected. 

 
 
 

Example 
     Create a file  



 
Click on Data->split file 
 

 
 
We split according to the gender variable use above options 
Then click ok 
Then take analyze-> descriptive statistics->descriptive 



 
 
Use above case like this and click ok 
 

 
 
 
 
 
 
 
 
 
 



Select Cases 
Select Cases provides several methods for selecting a subgroup of cases based on criteria that include 
variables and complex expressions. You can also select a random sample of cases. The criteria used 
to define a subgroup can include: Variable values and ranges. Date and time ranges. 

 

To select cases for inclusion into analysis call up Data > Select Cases 

 

Several options are offered: 

 All Cases (default initial setting) Use it to remove a filter you have 
defined. 

 If condition is satisfied: selects cases that satisfy a condition (logical 
expression ) you specify after selecting the If button. This is the most 
important option; see further explanations below. 

 Random Sample of Cases case selection based on a random sample. 
The Sample button lets you specify e.g. the percentage of cases to 
select. [This corresponds to the SAMPLE command] 

 Based on time or case range Mainly useful with time series data. Select 
a specific period or analysis. 

 Use filter variable Selection based on a filter variable: A dummy variable 
with 0's and 1's, where values of 0 are excluded and values of 1 
included. [This corresponds to the FILTER command. 

Towards the bottom you will find an Output box 

 Filtered out unselected cases removes unselected cases from analysis, 
but not from the data matrix. A filter remains active until turned off 
by Data > Select Cases > All Cases . When the filter is turned off, all initial 
cases are again available for analysis. [A the command language level 
this corresponds to the FILTER command] 

 Delete unselected cases Deletes all cases unselected from the data 
matrix, i.e. actually removes them and creates a subset of the initial 
cases. If you want the original cases back, you will need to re-read the 
original file.[At the command language level this corresponds to 
the SELECT IF command] 

 Copy selected cases to a new dataset copies the selected to a 
new dataset, visible in a new data editor window; the original dataset is 
not changed and unselected cases are not copied to the new dataset. 

 

 



Example 

Create  a spss file  

 

 
Click on data->select cases 

 
 
 
Make the above option 



Then click on if button 

 
Enter the above condition as above 
Then click continue button  then ok button 

 
 
 
 
 
 
 
 
 
 



Table look 
For making the output report of table look in different colours and style  
Right click on table then table look menu clicking  
 

 
Then choose any style for table 

 
 
Click ok 



 
 
Compute total score 
 
 
Sometimes you may need to compute a new variable based on existing information 
(from other variables) in your data. For example, you may want to: 

 Convert the units of a variable from feet to meters 
 Use a subject's height and weight to compute their BMI 
 Compute a subscale score from items on a survey 
 Apply a computation conditionally, so that a new variable is only computed for 

cases where certain conditions are met 
Example 

   Create a a sample spss file contains three variable id,stat1,state2, here we want to computer state1 
and state2 to new variable  

Step1. Create a spss file having three variable 



  

Its variable view is  

   

 

Step 2: To compute a new variable, click Transform > Compute Variable. 

 



Target Variable: The name of the new variable that will be created during the 
computation. Simply type a name for the new variable in the text field. Once a variable is 
entered here, you can click on “Type & Label” to assign a variable type and give it a label. 
The default type for new variables is numeric. 

The left column lists all of the variables in your dataset. You can use this menu to add 
variables into a computation: either double-click on a variable to add it to the Numeric 
Expression field, or select the variable(s) that will be used in your computation and click 
the arrow to move them to the Numeric Expression text field (C). 

C Numeric Expression: Specify how to compute the new variable by writing a 
numeric expression. This expression must include one or more variables from your 
dataset, and can use arithmetic or functions. 

When writing an expression in the Compute Variables dialog window: 

 SPSS is not case-sensitive with respect to variable names. 
 When specifying the formula for a new variable, you have to option to include or 

not include spaces after the commas that go between arguments in a function. 
 Do not put a period at the end of the expression you enter into the Numeric 

Expression box. 

The center of the window includes a collection of arithmetic operators, Boolean 
operators, and numeric characters, which you can use to specify how your new variable 
will be calculated. There are many kinds of calculations you can specify by selecting a 
variable (or multiple variables) from the left column, moving them to the center text 
field, and using the blue buttons to specify values (e.g., “1”) and operations (e.g., +, *, /). 

If: The If option allows you to specify the conditions under which your computation will 
be applied. 

Function group: You can also use the built-in functions in the Function group list 
on the right-hand side of the window. The function group contains many useful, 
common functions that may be used for calculating values for new variables (e.g., mean, 
logarithm). To find a specific function, simply click one of the function groups in 
the Function Group list. You will now see a list of functions that belong to that 
function group in the Functions and Special Variables area. If you click on a 
specific function, a description of that function will appear in the text field to the left. 

 

Enter name target variable name  totalstat   and in numeric expression box give 

 Sum(stat1,stat2) 



 

Then click ok 

 

 

Diagrammatic Representation 

We can use different chart like piechart etc 

Click on analyze->descriptive statistics->frequency 

 

Then click on chart 



 

 

Select any chart 

Then click continue ok 



 


